HWBOT
  1. HWBOT
  2. HWBOT-923

Unigine Heaven: validation screenshot and checksum not shown on submission page

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: hwbot v5, hwbot v5.5.0
    • Labels:
      None

      Description

      If people submit a score now, the validation picture and checksum is not saved.

      Example: http://www.hwbot.org/submission/2341914_moose83_unigine_heaven___xtreme_preset_%28dx11%29_radeon_hd_7970_3288.97_dx11_marks
      1. log.txt
        16 kB
        Dennis Devriendt
      2. results.html
        293 kB
        Dennis Devriendt

        Activity

        Dennis Devriendt added a comment -
        I'm having a hard time tracking down the cause of this issue (specifically that the validation picture isn't linked, the checksum issue is easily fixed). What I found out:

        - the image is saved on the amazon cloud but the image_id isn't linked to the result, instead image_id is 0
        - this does not always happen. I found a good example, Knifemind made a Xtreme and a Basic submission a few minutes apart. One had the image, the other one had not.
        http://hwbot.org/submission/2342655_
        http://hwbot.org/submission/2342649_
        I attached the relevant logs for both submissions. As far as I can tell they are pretty much identical
        - I just can't seem to reproduce this
        - It most likely started since the latest deploy. It has happened now and then in the past but since the latest deploy, almost 50% of the heaven results are affected. I've attached a list of results with some data

        - image id is set in SubmitController line 829: result.setImageId(form.getImageId());
        - image id in the SubmitResultForm is set around line 405:
        if (dataForm.getImage() != null) {
        // HWBOT-411 Unigine submission: 'prepopulate' screenshot
        Image image = imageService.scaleAndStoreImage("image", dataForm.getImage(), null, user, null, null);
        if (image != null) {
        form.setImageId(image.getImageId());
        } else {
        log.error("Failed to store image from dataform! " + form.getImage());
        }
        }
        - the log.error line never appears in the log, so I think it must be that image.getImageId() sometimes returns 0, but that method returns the primary key in the database, image.image_id and there IS a db entry in the image table for each upload image.
        - for each submission, the screenshot is uploaded 3 times to Amazon. This should be fixed but I don't think it has anything to do with this issue.
        Dennis Devriendt added a comment -
        Crossposting what I posted on the forums:

        Wow, finally fixed. We discovered 2 weeks ago that sometimes screenshots weren't added to heaven submissions. I spent a lot of time trying to reproduce it but just couldn't find out what was wrong. Turns out the screenshot id got set to 0 when you edited a submission that requires a datafile. Welp .

        The good news is: it's fixed on the production server so this shouldn't be an issue anymore. The bad news: all submissions of the last 2 weeks that were made with a datafile and were editted still don't have the screenshot attached. I'll try to find a way to fix them but I think we'll only be able to fix it by cross-referencing the submission timestamp with image timestamps and manually fixing them in the database (I bet Pieter-Jan would love to do that).
        Build Server added a comment -
        Integrated in HWBOT v4 #2759 (See [http://dev.hwbot.org/job/HWBOT%20v4/2759/])
            HWBOT-923

        Unigine Heaven: validation screenshot and checksum not shown on submission page

        dennis :
        Files :
        * /hwbot/trunk/src/main/webapp/WEB-INF/views/submit/includes/submit.verification.jsp
        Build Server added a comment -
        Integrated in HWBOT v4 #2764 (See [http://dev.hwbot.org/job/HWBOT%20v4/2764/])
            HWBOT-923

        Unigine Heaven: validation screenshot and checksum not shown on submission page

        dennis :
        Files :
        * /hwbot/trunk/src/main/webapp/WEB-INF/views/submit/includes/submit.verification.jsp

          People

          • Assignee:
            Dennis Devriendt
            Reporter:
            Pieter-Jan Plaisier
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: