HWBOT
  1. HWBOT
  2. HWBOT-847

Disable forum password recovery e-mails

    Details

    • Type: Story Story
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: hwbot v4.6.12
    • Labels:
      None

      Description

      Email:

      "Hi,

      I am sending you this email becuase I cannot login to forums. I can login fine with main page and post comments but not on the forum.

      I have tried resettting my password but this doesnt work as I have not got a reset email from hwbot. I have done a thread about this issue and it was fine for a while but is not now.

      this is my account:

      http://hwbot.org/user/jimba/

      thank you,

      Jamie"

        Activity

        Dennis Devriendt added a comment -
        2 problems:

        - reset password mails from the forum don't arrive, this one is for Frederik :-)
        - editing your forum password via the main website profile didn't update the salt in the forum table, this should be fixed
        Build Server added a comment -
        Integrated in HWBOT v4 #2579 (See [http://dev.hwbot.org/job/HWBOT%20v4/2579/])
            HWBOT-847

        Forum password reset fail

        dennis :
        Files :
        * /hwbot/trunk/src/main/java/org/hwbot/facade/UserFacadeImpl.java
        Pieter-Jan Plaisier added a comment -
        The issue is sort of fixed: the user can now reset his forum password in his account settings (http://hwbot.org/profile/), but not in the forum directly. The problem here is that the forum mailer is not working. When a user tries to change his password through the forum, there will be a message that says "mail has been sent", but that's not true.

        So, two options:

        1) forum mailer gets fixed => user can change password both through frontpage and forum
        2) policy change: user can't change forum password through the forum => there should be a message saying the user has to change the password through the front page.

        What do you think, Frederik ?
        Dennis Devriendt added a comment -
        We'll go with the policy change, if a user lost his forum password, he should change it on the main website in his profile. We should add a message on the forum password recovery page that guides the user to his main website profile.
        Pieter-Jan Plaisier added a comment -
        Okay, great. So, let's close this task and create a new one for the message ?

          People

          • Assignee:
            Dennis Devriendt
            Reporter:
            Pieter-Jan Plaisier
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: